Amsterdam
info@jaheli.nl

New firmware V1.3 update DED for DCS

At March 2022 there was a new plug-in update for the F16 viper in DCS-Bios.
This version was not compatible with Version 1.1 of the DED box for DCS.

If you want to use the latest plug-in version with DCS-Bios you need to update the DED box.
At the download page you can download the latest version 1.3
Manual is in the zip file.

THIS UPDATE IS NOT NEEDED FOR THE BMS VERSION!!!